Ruger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have almost new Ruger 10/22 (standard one, no customization), shot about 200-300 rounds. Last time after cleaning I realized I can't insert magazine (tried two standard mags and one BX-25, same result). Bolt is moving back and forth ok, trigger group also seems ok (hammer works, trigger works, safety works, mag release works). I have a strong feeling this is because of ejector, I removed ejector and magazine entered freely. But ejector itself looks ok (no dents, chips,etc). Is there any idea what it could be?
 

Attachments

·
Registered
Joined
·
269 Posts
Not trying to disparage any of your efforts, but in my admittedly limited experience, if the 10-22 is assembled correctly, the magazines will go in with no trouble, and even if it is not assembled exactly right. I found that out when I assembled my DSP with the ejector flopping around in the receiver. Your pixes show what looks to me like a normal, run-of-the-mill 10-22 action. Good luck with your search for a remedy.:)
 

·
Registered
Joined
·
229 Posts
your ejector is upside down... happens to all of us... i had a problem recently on reset after a cleaning disassembly, and found that the mag release spring hadn't been captured properly...

willie
on the Gulf of Mexico

p.s. don't ever force your action if something isn't working! (although fortunately, parts are cheap)...
 

·
Registered
Joined
·
39 Posts
I got to looking at the pictures and I actually took my trigger assembly out as a comparison and looked..yup..the ejector is upside down. Good catch Linux.
Don't sweat it OP..it happens.
 
1 - 6 of 6 Posts
Top