Ruger Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a mini 14 tactical I purchased last year . Tonight at the range I was testing out some new tapco 30 round mags.
1st mag loaded w/20 rounds : no prob
2nd mag -20 rnds-no prob
3rd mag - 30 rnds 3 failure to extract
4th mag -20 rnds- 2 failure to extract
5th mag- 10 rnds- 2 failure to extract

I was so disappointed I immediately blamed the mags, but the more I thought about it ,I can't really see how the mag would cause an extraction issue.

My daughter's father in law had to have a bolt repair in a brand new mini14 Ranch 2 years ago.

Anyone else have any issues like this?

Got back late so I have not torn down rifle yet.
 

·
Registered
Joined
·
15 Posts
I have a mini 14 tactical I purchased last year . Tonight at the range I was testing out some new tapco 30 round mags.
1st mag loaded w/20 rounds : no prob
2nd mag -20 rnds-no prob
3rd mag - 30 rnds 3 failure to extract
4th mag -20 rnds- 2 failure to extract
5th mag- 10 rnds- 2 failure to extract

I was so disappointed I immediately blamed the mags, but the more I thought about it ,I can't really see how the mag would cause an extraction issue...
Why not? The magazines are an integral part of a firearm and designed to work as part of a system. How does your mini function/extract with OEM Ruger mags?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3 (Edited)
Haven't had any problems, I just don't see how the mag could stop the bolt from extracting the spent shell. Rifle fires, bolt goes back,strips new round,causing double feed. I know I need to go back with my factory mags ,just curios if any one else has had this problem.
 

·
Registered
Joined
·
370 Posts
Send it back to Ruger . After my 582 Tactical went back twice they just sent me a new 583 Tactical. This has been pretty common , check out" the perfect union " forum and you will read plenty about it. I think that Ruger had a bad run of outa spec bolts JMHO but we will never know. My 583 runs perfect and as always Rugers C/S is the best. Run Ruger Factory Mags.
 

·
Registered
Joined
·
251 Posts
Send it back to Ruger . After my 582 Tactical went back twice they just sent me a new 583 Tactical. This has been pretty common , check out" the perfect union " forum and you will read plenty about it. I think that Ruger had a bad run of outa spec bolts JMHO but we will never know. My 583 runs perfect and as always Rugers C/S is the best. Run Ruger Factory Mags.
I second this
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Went back today with factory mags, ran perfect. I also have. Mini 30 since the 90's ,so I know factory mags work best. Was hoping there was finally a cheaper version. Disappointed once again !
 

·
Registered
Joined
·
15 Posts
Went back today with factory mags, ran perfect. I also have. Mini 30 since the 90's ,so I know factory mags work best. Was hoping there was finally a cheaper version. Disappointed once again !
Glad to hear the mini is rocking n rolling again. BTW, did you see that CDNN has 20rd OEM Ruger Mini-14 mags on sale for only $19.99? It might be a good time to stock up!
 

·
Registered
Joined
·
370 Posts
Glad to here that that was all it was. Don't feel Like the Lone Ranger I think almost all of us have tried to get aftermarket mags run like the factory's. But I just manned up to the factory's and never looked back. Bye once cry once. I know , I wish they wern't so dammed $$$$ but you just gotta shop the inner web and you'll find some good deals.
 

·
Registered
Joined
·
865 Posts
yup mine had similar problems!!!!!!!!!!!!!!!!

I have a mini 14 tactical I purchased last year . Tonight at the range I was testing out some new tapco 30 round mags.
1st mag loaded w/20 rounds : no prob
2nd mag -20 rnds-no prob
3rd mag - 30 rnds 3 failure to extract
4th mag -20 rnds- 2 failure to extract
5th mag- 10 rnds- 2 failure to extract

I was so disappointed I immediately blamed the mags, but the more I thought about it ,I can't really see how the mag would cause an extraction issue.

My daughter's father in law had to have a bolt repair in a brand new mini14 Ranch 2 years ago.

Anyone else have any issues like this?
yup
mine was built in dec, 2011 and needed a new bolt. didn't notice it until a year or so after I bought it, and had nothing but problems. sent it back to ruger in NH and they fixed it right........................................!!!!!!!!!!!!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #17
Ruger sent me new extractor, plunger and spring. Changed out the plunger and spring. Will see if new plunger gets chewed up like the original.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #19
Changed out plunger and spring. Was sent a silver extractor ,which looked to be slightly different than the one tat came in the rifle,so I stuck with original. Works great
 
1 - 19 of 19 Posts
Top