Ruger Forum banner

Status
Not open for further replies.
1 - 20 of 34 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
New to the forum and just wanted to say hello. I have a ruger 1911 first 1911 from them and so far love the weapon with one issue, feeding. I've had the weapon returned to ruger and they replaced the extractor and the first 100rds it seemed to be fine. I went to the range again and after about 25rds it started to miss feed, has anyone else experienced this issue? I'm waiting to hear back from ruger about this. I've had it for about 8 months and put 800rds down range when it started, my rock island has had over 2k rds and no problem.
thanks
Harry
 

·
Registered
Joined
·
17,236 Posts
Welcome from the Texas Panhandle.
 

·
Registered
Joined
·
7,654 Posts
Welcome from Wisconsin
 

·
Registered
Joined
·
4,795 Posts
Welcome from NW Georgia. Try asking your question in this forum - likely to get more answers there.
 

·
Double P90 Shooter
Joined
·
19,890 Posts
Welcome from the Republic of Texas...
 

·
Exalted One
Joined
·
1,784 Posts
Welcome from Central Virginia! Can't help you with your 1911 problems, but I'm sure someone will come along.
 

·
Registered
Joined
·
1,575 Posts
Welcome from Iowa! You'll find lots of great people and good information in this cyber community.

My SR1911 was a bit finicky about ammo for a while... I switched around using various manufacturers ammo... and then it settled down. I also shoot my own reloads now.
 

·
Super Moderator
Joined
·
16,338 Posts
Hello Harry ... Welcome from SW Ohio ... Glad to have you aboard!
 

·
Registered
Joined
·
10,286 Posts
Welcome to the forum
 
1 - 20 of 34 Posts
Status
Not open for further replies.
Top