Ruger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Good Morning All!

I recently purchased an AR556 and while the trigger breaks cleanly the pull is very heavy. I installed a Wolff reduced power trigger spring set and cleaned up the contact points on the trigger group. The trigger is a bit improved, but now an issue has developed where when I depress the mag release it hangs up on something and holds open, not returning all the way to its home position. :confused:

I have fired about 500 rounds through the rifle prior to working on the trigger and never experienced this issue, and I have never had the mag release out or work done to it. Not sure what to investigate next.

Thanks for your assistance!
 

·
Registered
Joined
·
1,008 Posts
Look at the mag release button, do you see the threaded post from the mag catch? is it recessed aways?, it should be relatively flush with the mag release button. If it is recessed, use a wooden dowel or something similar and push the mag release button all the way in, this pushed the mag catch out the other side enough so you should be able to screw it in one more turn. Release mag release button, and give it a function test.
 

·
Registered
Joined
·
1,008 Posts
There isn't really anything to do with the trigger job that would affect the mag release. If the above isn't a solution, you can also use that method to unscrew the mag catch, remove the button and spring and inspect to make sure there is no debris in there for it to hang up on.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
Thanks, I'll Check It Out!

Thanks crracer, I am fairly new to AR's and noticed while inspecting the lower that the mag release parts are all contained forward of and enclosed away from the trigger group. I'll troubleshoot and let you know the results. Have a great weekend!
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #5 ·
Problem Resolved

Thanks again crracer 712. I ended up removing the mag release and checking the components (all seemed well). Once reinstalled I threaded the mag release so it was just past flush on the release and it seems to work well. I'll have to run it at the range, but for now the problem seems resolved.
 

·
Registered
Joined
·
1,008 Posts
Glad you got it fixed, if it's dropping mags at home (empty mags?) should be good to go.

I've built 5 AR's now and the mag release is the second thing I install and test it as soon as it's installed with a 10 round pmag, if those drop freely, they've always been GTG with any mag.
 
1 - 6 of 6 Posts
Top