Ruger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I followed a YouTube tutorial and everything looked to be going well. Everything functioned and went together just as they did in the video. Now I noticed after I put it together the safety is loose. It still works but it's loose. I made sure to put in the spring correctly, but maybe it slipped a little bit when assembling it together? I'm not sure.

Anyways, the big problem is that now that I've put it all together and go to pull the trigger, it won't fire. It functions how it did without a magazine disconnect even with a magazine in it. The trigger doesn't pull very far at all. So the problem with this is I don't know how to disassemble the gun again. I can't pull the trigger so I can't remove the slide. Any suggestions on how to get the slide off without needing to pull the trigger to release the striker?
 

·
Registered
Joined
·
27 Posts
I saw another post somewhere similar to this a while back. Go see a gunsmith you can trust. That's why I had mine done by a smith in the first place. He even commented on hard it was to get back together. Good luck.
 

·
Registered
Joined
·
385 Posts
You need to take out the 2 large pins that hold the trigger assembly in the frame, then you can cycle the trigger bar which will release the slide.

I just removed the magazine disconnect in our 2 LC9s in under 10 minutes, those YouTube videos have you remove way too much stuff for what you are in there to do.

Steve
 
1 - 3 of 3 Posts
Top