Ruger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
I was having some accuracy issues, more than usual. It has never been an accurate gun, 4 - 5" at 100 but fun for plinking and an occasional 3 gun where most of the shots are 15 - 50 yards with an occasional 8" gong at 100. Usually no issues. And best of all, very few loading or ejection issues and never in a match, using nickel Pro-mags.

I did notice some wear on the extractor and pin but couldn't tell what was happening. While zeroing a new red dot, my group suddenly went to 5 - 6" at 50 yards. I had someone else (much better shot than me) try and had the same result.

Took it home to clean and noticed much more damage to the extractor than before and it appears that the extractor part of the bolt is contacting the shroud around the breech (is it called a barrel extension like an AR?).

Took it to the LGS where I got it and they said immediately to send to Ruger. Nothing yet but I will advise.

I did have a Midwest Gunsmith (GunDoc) trigger job but that was 2 years ago but pretty sure it shouldn't affect anything with the barrel.

Anyone ever run into anything like this?
 

·
Registered
Joined
·
370 Posts
What series is the gun and how long have you had it ? Sending it to Ruger is a smart move there CS is great . Keep us posted and when they fix it make sure to ask what caused the problem .
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #3 ·
582 series and Ive had it about 2 years.
It's been running hot and cold the whole time. Every time I thought about sending it back for a repair it would behave for a while.
 
1 - 3 of 3 Posts
Top