Ruger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
I received my new compact stock from Ruger today, for my Ruger American Ranch Rifle in 5.56. It came with the AR mag adapter. Before inserting the adapter into the stock the mag release button works properly. After inserting it into the stock the button is locked and can't be pressed. If I were to pull the adapter out just a few millimeters it works. Something is blocking it when fully inserted into the stock.

I called customer service but they were closed today and won't reopen until Monday.

Does anyone have a very simple solution to this?

Thanks in advance!
 

·
Cat Herder
Joined
·
1,625 Posts
I received my new compact stock from Ruger today, for my Ruger American Ranch Rifle in 5.56. It came with the AR mag adapter. Before inserting the adapter into the stock the mag release button works properly. After inserting it into the stock the button is locked and can't be pressed. If I were to pull the adapter out just a few millimeters it works. Something is blocking it when fully inserted into the stock.

I called customer service but they were closed today and won't reopen until Monday.

Does anyone have a very simple solution to this?

Thanks in advance!
Which stock came with the adapter, the original or the new one? I'm not positive, but I think I remember reading that the 2nd Gen rifles had some minor changes to use AR mags, more than just the stock itself. If your rifle is a 1st Gen and your new stock is 2nd, that may make them incompatible.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
I bought it from the original owner. The S/N is 69032xxxx and the S/N lookup says it was shipped in 2018.

I ended up trying the original tan adapter in the new black compact stock. It works. I put the new black adapter into the original tan stock and it doesn't work.

You may be right. I'll call Ruger tomorrow.
 
1 - 3 of 3 Posts
Top