Ruger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
How's everybody doing? New guy lookin for some SR9 input.. I'm a first time Ruger owner and was very pleased when I saw the new SR9. I've never been drawn to a Ruger before so I was shocked when I realized who the manufacturer was (no disrespect). Anyway picked one up at the local gun show and couldn't wait to put some rounds through it. First 100 rounds and I was pleased (no problems what so ever), went back for some more and now I'm worried. During the next session with 200 rounds the trigger would not reset to the ready position. The bullet indicator was up, but the trigger was still back in the fired position? I had to cock the slide back slightly to get the trigger to return to ready and chamber a round on 5 different occasions. I'm wondering if anyone else had this problem? I already field stripped it and removed the factory lubrication as best as I know how. Was wondering if anyone had a fix that they can school me with?
 

·
Registered
Joined
·
235 Posts
My recomedation would be to contact ruger and let them know whats going on. most like they will have you send it in to them. They should cover shipping both ways it being such a new gun.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for the input..I'm waiting on my recall package and then I'm gonna call and let them know what's happening. Just did a good cleaning and lube on it and waiting for the chance to shoot to see if it happens again. I'll be posting an update at that time.
 
1 - 3 of 3 Posts
Top