Ruger Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My ruger SR40c has been giving me some problems. Hoping I can get so good advice. When I load my Mags it seems that that last one will not feed it hangs up (stovepipe).. It does this on both mags. It happens about every other time I reload. Also I have been getting about 10 light strikes out of every 50 I fire. I have only fired 175 rounds so far. Will this get better as I fire more rounds or this something that I need to address with ruger or something I can correct. Any help will be greatly appreciated.
 

·
Ruger Tinkerer
Joined
·
11,898 Posts
warrior, I don't think this will get better on its own. I've put over a thousand rounds through my SR40 & SR40C without any of the problems you describe. I've had a very rare FTE once in a while but no light strikes or stovepipes. If you give Ruger CS a call they will be happy to help no doubt. I'm not sure what to tell you to try on your own since I've not had any of these issues. Perhaps others will be along with more ideas.

And welcome to the forum by the way! If you're a Ruger owner this is the place to hang out. Good bunch of friendly folks here with lots of help and support.

Wave
 

·
Registered
Joined
·
334 Posts
You'll probably be interested in this recent thread... click:

http://rugerforum.net/gunsmithing/59794-my-sr40c-refurbishing-project.html

I had bought a used one which was giving me about 20% light strikes too... Must be why the guy wanted to trade...er... "dump"... it on me. I'm a natural tinkerer and enjoyed getting it to run right but if you're not, you better send it in to Ruger for a fix.

When they're right, they're GREAT!... Don't settle for less.
 

·
Registered
Joined
·
8 Posts
My only problem with my sr40 was every time I rammed the magazine in place while the slide was back it closed all on its own....it was still new at the time, after about 500 rounds out doesn't do it any more!!! Like butta'
 

·
Republican!!!
Joined
·
11,413 Posts
Good luck on finding your problem. Are there any more mags you can try? The type of jams suggests some "limp wristing". Also, make sure there is nothing obstructing the mags from fully seating. I'd also advise you to check that all is in order with your mag release.

These are just ideas. I've never had a jam or misfire with my SR40c.
 

·
Registered
Joined
·
332 Posts
My ruger SR40c has been giving me some problems. Hoping I can get so good advice. When I load my Mags it seems that that last one will not feed it hangs up (stovepipe).. It does this on both mags.
Would like clarifying your above explanation? I realize your explanation seems perfectly clear to, but to the reader I see the possibility of a misunderstanding.

When you say "that last one will not feed it hangs up (stovepipe).." do you mean the last one you loaded into the mag which would be the first one out of the mag when you insert the mag into the gun?

Or the last first one you loaded into the mag which would be the last one out of the mag when shooting?

In other words, is the stovepipe occurring when the slide is operated by recoil when the gun is fired? Or is the stovepipe occurring when the slide is operated manually?

If you're saying the first one out of the mag [the one you're manually inserting into the chamber] I would suspect the problem is in the way you're operating the slide.
 

·
Registered
Joined
·
3,855 Posts
My ruger SR40c has been giving me some problems. Hoping I can get so good advice. When I load my Mags it seems that that last one will not feed it hangs up (stovepipe).. It does this on both mags. It happens about every other time I reload. Also I have been getting about 10 light strikes out of every 50 I fire. I have only fired 175 rounds so far. Will this get better as I fire more rounds or this something that I need to address with ruger or something I can correct. Any help will be greatly appreciated.
Send it into Ruger. Do it now. My SR40c had the same light strike problem; at least one light strike per magazine. I sent it into Ruger and 8 days later I had the gun back. After about 500 rounds not one single light strike or any other issue whatever. Seriously. Let them fix it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
I sent my SR40c to ruger today. The customer folks were real nice. To the reply above from Trucker. The last round in the mag would not feed propertly. The 1st round loaded is the last round fired.
 

·
Registered
Joined
·
3,855 Posts
I sent my SR40c to ruger today. The customer folks were real nice. To the reply above from Trucker. The last round in the mag would not feed propertly. The 1st round loaded is the last round fired.
Good move. You will be glad that you did. When they send the gun back next week there will be a document in the box that tells you what they did. A nice thing to keep in the original gun box.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Sent my SR40C to Ruger for repairs and they have already sent it back to me. One week turnaround. That is great customer service. Wiil take to range and see how she does.
 
1 - 10 of 10 Posts
Top