Ruger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello I have a speed six that when you pull the hammer back quickly it misses the spot where it would stop in single action. If you pull it slowly it will catch, stop and fire correctly.

There are no issues using it in double action.

I’m just checking to see what may be off or needs attention.

Thanks, Mike
 

·
Retired Moderator & Gunsmith
Joined
·
16,187 Posts
mikey502, Sounds like a kitchen table gunsmith did a trigger job???

The sear notch in the hammer is very thin, even with a brand new hammer. My guess is someone removed some metal from the sear notch or the tip of the trigger extension to lower trigger pull and went too far. It pretty hard to put metal back so you may have to buy a new hammer and/or trigger. Herein lies the problem ….. the Security-Six family of revolvers have been out of production since 1988 so Ruger no longer provides parts or service for them. You might be able to pick up a used hammer / trigger from Gun Parts, Inc. BTW, a Security-Six hammer and trigger are identical to the Speed-Six.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks I will start there. I was hoping it was maybe assembly error on my part as I received it as a box of parts but that may be why is was disassembled.

Thanks for somewhere to start figuring it out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Found a new old stock trigger. That took care of the problem. Thanks for the assistance.
 

·
Super Moderator
Joined
·
21,269 Posts
Now take it out and shoot it and post up some pics.
 
1 - 6 of 6 Posts
Top