Ruger Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi guys and RUGER COMPANY,

I bought 2 practice round for my Ruger SR40 last month November 2012. When I got home, I put the 2 practice round in the magazine, insert in the pistol and pulled the slide to load the practice ammo in the chamber but when I released the slide, the practice ammo didn't feed completely coz the firing pin blocked it. Everytime I load the ammo the firing pin block it.

I try to open the slide, insert the magazine with practice ammo then release the slide with full tension of the spring and it loads but when I pull the slide to reload the remaining bullet same problem occur the firing pin block it.

Any feedback, comment or suggestion with this issue .
 

·
Registered
Joined
·
590 Posts
It sounds to me like you're not pulling the slide back with enough force. If you pull the slide back too slow the the round that is already chambered won't eject properly. Try pulling the slide back faster with more force. Hope this helps.
 

·
Registered
Joined
·
786 Posts
I have the SR9c and had a similar problem. In order for a round to chamber, you need the full force of the spring bringing the slide forward. You can't "ride" the slide with your hand, you need to pull the slide back all the way, and let go of the slide so that it slams forward with full force. It needs the extra push to get the nose of the bullet started going up the ramp.

You're saying that the firing pin is blocking the round, I'm assuming that you mean the striker. What I was seeing was the nose of the round jammed on the bottom lip of the feed ramp with the striker pushing on the round.

The real test will be how it performs when actually firing the gun.

Hope this helps.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top