Ruger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
44 Posts
just looking for an answer for peace of mind. This has to do with the trigger not reseting some of the time and happend with both mags.

I have a fairly new Ruger SR9 and had some reset issues. I shot 150 rds with not a single problem. I then took out the mag disconect and had 6 reset issues. I then put it back in and it went away for the last 250 rds. I dont see how the mag disconect could have caused this. The only other thing I can think of is that when I went to put it back in I sprayed some compressed air in the FCH area and a drop of oil and spread it around with the air. Any suggestions would be greatly appreciated. The gun is running great and mabye it just needed to be broken in?? I want to trust this gun and its just bothering me that it did this as I have a SR1911 with 1500rds and not a single issue.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #2 · (Edited)
The lady at Ruger told me today that the SR9 is not supposed to fire without the mag disconect taken out . I think she has to say that, because I do not see that being the issue. Yes I know they frown on taking parts out and she let me have it, thats for sure. I just want to get to the bottom of this.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #3 ·
anyone?? I know there are more of you out there. Put another 150rds through it today and not one single problem. I even took the mag disconect for 30rds to see and it worked flawlessly also. Mabye just a burr or some dirt?? My trust is starting to happen with this firearm and am really liking it.
 

·
Registered
Joined
·
135 Posts
I,ve had my MDC out for about 200 rds with out any trouble. shot every thing from 115gr to 147gr bullets with picked up range brass.
 

·
Registered
Joined
·
7,096 Posts
just looking for an answer for peace of mind. This has to do with the trigger not reseting some of the time and happend with both mags.

I have a fairly new Ruger SR9 and had some reset issues. I shot 150 rds with not a single problem. I then took out the mag disconect and had 6 reset issues. I then put it back in and it went away for the last 250 rds. I dont see how the mag disconect could have caused this. The only other thing I can think of is that when I went to put it back in I sprayed some compressed air in the FCH area and a drop of oil and spread it around with the air. Any suggestions would be greatly appreciated. The gun is running great and mabye it just needed to be broken in?? I want to trust this gun and its just bothering me that it did this as I have a SR1911 with 1500rds and not a single issue.
I had trouble with mine a while back & it was I did not follow the video instructions on Rugers website regarding re-assembly. If you do not make sure the trigger is forward before re-installing the slide, you can have trouble.
Watch the videos! or where you live you could walk over to Ruger
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #6 ·
yes. I watched the youtube on them. I am thinking now that it was dirty or mabye a burr as I have had another 500rds with out a single problem and is becoming my go to gun. I like the SR 1911 but I like the 17rds capacity of the SR9. Now Ruger just needs to make a double stack 1911 in 9mm, I think that would be a big hit.
 
1 - 6 of 6 Posts
Top