Ruger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
I have a Q-Erector suppressor Erector™ by Q that works very well on my CZ-455 bolt-action 22lr. At 25rd, 10 shots are one ragged hole.

With my Ruger 10/22 Take-down, shots are wild, spread L/R/U/D 6 inches using CCI 22lr Suppresser or 22lr Mini-Mag ammo. Without the suppressor, both ammos shoot one ragged hole. So, it seems the 10/22 TD works poorly with my suppressor.

As I have a Ruger threaded barrel for the 22lr TD, it seems that there was some expectation it might work with a muzzle device, but perhaps not a suppressor? Or might my suppressor have too much back pressure for the TD? I can remove segment from the suppressor but thought I might check here first to see if this is known issu.

Thanks for the help!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
I put that suppressor on my CZ455 today and confirmed 3 shots dead-center at 25yd and saw no change from last Fall using the same brand of ammo - CCI 22lr Suppressor but different a lot. It’s some thing about that suppressor on the 10/22TD. It cycles fine with the subsonic ammo. Maybe the back pressure is too high and venting from the barrel/receiver connection?
 

·
Registered
Joined
·
34 Posts
Yours is about the same as my SEG. Here's the web site.

You should be able to have three different configurations for use with rifles and pistols.
Try the shortest on the 10/22. Here is a great review of yours.
seg.jpg
 

·
Cat Herder
Joined
·
1,632 Posts
Are you using a scope or sights on the 10/22? If using a scope maybe try increasing the tension knob? Or compare with the iron sights. The extra weight on the muzzle could be increasing play in the barrel to receiver connection causing you to lose zero.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
After closer inspection, it seems that there is a rim of machining scarp left at the base of the threaded muzzle that holds the Suppressor from tightening down flush. Maybe that's causing gas leakage blowback? I filed it down flat and will try again.I picked up some shim washers too and with add one if still not grouping well.

I tried hanging a sock with sand over the barrel without the Suppressor on and the added weight doesn't change POI spread, so it's not likely to be that Suppressor weight. But worth checking, thanks.The vendor asked if the Suppressor was aligned, tight and the 1st blast cone not touching the muzzle, and I confirmed those we not the issue.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Yep - that metal scrap was the issue - good groups now that it’s filed off flat. In fact, I get a few FTF every 25rd mag, probably from gas back pressure. Would a different spring help that cycling issue?
 
1 - 6 of 6 Posts
Top