Ruger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just installed the Mark II bushing and reassembled the Mark III 22/45 per the instructions on Bullseye's page, but my safety does not work at all. What did I do wrong and how to I correct this?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Hm. I guess it just took a reinstall of the guts. Now the safety works. However, everything is so loose compared to how it was stock.

Now I have a problem after doing the slingshot mod. The hammer won't drop, I guess. Any ideas why? I'm taking a look at the troubleshooting page trying to figure it out.
 

·
Registered
Joined
·
49 Posts
Sounds like you are having trouble tensioning the sear spring.

Use the safety to hold the sear while installing the hammer bushing, hammer and disconnector, it a little tricky holding the safety, lining up the hammer pin and making sure the sear spring ends up on the back side of the hammer pin, but it can be done,lol.

Once you have it back in install the MSH (main spring hsg.) and check the function with the upper off, cock the hammer apply safety, drop the safety and hold your finger in front of the hammer to keep it from going to far forward and pull the trigger. Every thing should work before installing the upper.

good luck!
 

·
Larry the Conservative
Joined
·
5,458 Posts
One problem I had when I did mine was to lose the little bity plug that acts as a saftey detent. I found it in the floor a couple hour later, but its very, very small and finding it was pure luck.
 
1 - 4 of 4 Posts
Top