Ruger Forum banner

1 - 13 of 13 Posts

Registered
Joined
5 Posts
Discussion Starter #1
I recently purchased my first AR and my first Ruger. After purchasing a QD sling mount, I discovered that either gas block is too thick, or the channel that was cut for the sling mount bearings isnt in spec. Has anyone encountered the same issue? Do I need to file the block to the correct spec? I asked a local gun store to try connecting a sling mount to another Ruger AR 556 and one of the two he had in stock has the same
problem.
 

Registered
Joined
1,040 Posts
What type sling mount button/buttons does it have ? Push in with button on the end or pull 2 side tabs down while pushing the QD swivel in. Can you add a picture of it?
 

Registered
Joined
1,040 Posts
When you push the button, and push the swivel in the hole at the same time, it doesn't push in ?
 

Registered
Joined
1,040 Posts
I bet the swivel post is to long. Mine is a Magpul swivel, stupid thing was $27.00 I almost fell over, but it fits perfect.
 

Registered
Joined
5 Posts
Discussion Starter #8
I dont think the post is too long since the end of the post is not hitting the end of the hole. I havent measured it yet, but I believe the channel was cut too deep inside the gas block.
 

Registered
Joined
4,030 Posts
I hate those push button swivel mounts (QD). Too easy to bump and pop open. I prefer the post type that actually lock with a pin inserted through a hole and the pin has a lock on the opposite side. Most don't swivel, but I've never had any issues with them just popping open.
 

Emperor
Joined
885 Posts
Before messing around with your front sight tower sling swivel socket I would try a different sling swivel. I have not had any trouble getting a couple of different brands of sling swivels to work on my AR556 but I have seen multiple reports of sling swivels that have either fit to loose or too tight in various brands of ARs while a different brand worked fine. It may be that the sling swivel you bought is simply out of spec.
 

Registered
Joined
4,030 Posts
Before messing around with your front sight tower sling swivel socket I would try a different sling swivel. I have not had any trouble getting a couple of different brands of sling swivels to work on my AR556 but I have seen multiple reports of sling swivels that have either fit to loose or too tight in various brands of ARs while a different brand worked fine. It may be that the sling swivel you bought is simply out of spec.
I agree. It's a "get what you pay for" and there's a TON of cheap junk knockoffs (made for airsoft) out there being sold "as the real deal". Best to spend a little extra for a known name brand that will back their product and replace the problem, no questions asked.
 
  • Like
Reactions: *Shoot*

Registered
Joined
5 Posts
Discussion Starter #12
Thanks thats solid advice. The current swivel I鈥檓 having trouble with is made by 5.11 I will try one made by Ruger or the one me mentioned with the pin. I might also try filling the swivels itself rather than the block to get a fit.
 

Registered
Joined
4,030 Posts
Thanks thats solid advice. The current swivel I鈥檓 having trouble with is made by 5.11 I will try one made by Ruger or the one me mentioned with the pin. I might also try filling the swivels itself rather than the block to get a fit.
Magpul products have me spoiled. They're a bit pricey, but are quality built, reliable. and I can live with it. They've earned my loyalty over the years.
 
  • Like
Reactions: *Shoot*
1 - 13 of 13 Posts
Top